Netatalk 3.1.11 SRPM for Fedora and CentOS

From Netatalk Wiki
Jump to: navigation, search
(yum|dnf install, instead of rpm -i)
Line 6: Line 6:
  
 
This SRPM is tested on:
 
This SRPM is tested on:
*Fedora 26 x86_64 (rawhide 2016/11/23) (build fails because OpenSSL 1.1.0 has a bug)
+
*Fedora 26 x86_64 (rawhide 2016/11/28) [http://marc.info/?l=netatalk-devel&m=148035610507674&w=2 build fails]
 
*Fedora 25 Server x86_64
 
*Fedora 25 Server x86_64
 
*Fedora 24 Server x86_64
 
*Fedora 24 Server x86_64
*Fedora 23 Server x86_64
 
 
*CentOS 7 x86_64
 
*CentOS 7 x86_64
 
*CentOS 6 i686
 
*CentOS 6 i686
Line 19: Line 18:
 
== Build ==
 
== Build ==
  
At least, "'''rpm-build'''", "'''gcc'''" and "'''make'''" packages are needed.
+
At least, "'''rpm-build'''", "'''gcc'''" and "'''make'''" packages are needed. In case of Fedora, use "'''dnf'''" command. In case of CentOS, use "'''yum'''" command.
  
 
<blockquote>
 
<blockquote>
 
<tt>
 
<tt>
 
<pre>
 
<pre>
# yum install rpm-build gcc make
+
# dnf install rpm-build gcc make
 
</pre>
 
</pre>
 
or
 
or
 
<pre>
 
<pre>
# dnf install rpm-build gcc make
+
# yum install rpm-build gcc make
 
</pre>
 
</pre>
 
</tt>
 
</tt>
Line 55: Line 54:
  
 
Build by using "'''rpmbuild'''" command.<br />
 
Build by using "'''rpmbuild'''" command.<br />
If "'''error: Failed build dependencies: zzz'''" is displayed, execute "'''yum install zzz'''" or "'''dnf install zzz'''".
+
If "'''error: Failed build dependencies: zzz'''" is displayed, execute "'''dnf install zzz'''" or "'''yum install zzz'''".
  
 
<blockquote>
 
<blockquote>
Line 66: Line 65:
 
</blockquote>
 
</blockquote>
  
== Install or Upgrade ==
+
== Install ==
  
Install by using '''rpm'''" command.<br />
+
The RPM package is generated into "'''~/rpmbuild/RPMS/XXX/'''" directory already.
If "'''error: Failed dependencies: xxx is needed by...'''" is displayed, execute "'''yum install xxx'''" or "'''dnf install xxx'''".
+
 
+
If you install the netatalk for the first time, use "'''-i'''" option.
+
  
 
<blockquote>
 
<blockquote>
Line 77: Line 73:
 
<pre>
 
<pre>
 
$ cd ~/rpmbuild/RPMS/XXX/
 
$ cd ~/rpmbuild/RPMS/XXX/
# rpm -ivh netatalk-X.X.X-XXX.XXX.XXX.rpm
 
 
</pre>
 
</pre>
 
</tt>
 
</tt>
 
</blockquote>
 
</blockquote>
  
If the old netatalk already been installed, update by "'''-U'''" option.
+
Install by using "'''dnf install''''" or "'''yum install''''" command.<br />
 +
 
 +
<blockquote>
 +
<tt>
 +
<pre>
 +
# dnf install netatalk-X.X.X-XXX.XXX.XXX.rpm
 +
</pre>
 +
</tt>
 +
</blockquote>
 +
 
 +
or
  
 
<blockquote>
 
<blockquote>
 
<tt>
 
<tt>
 
<pre>
 
<pre>
# rpm -Uvh netatalk-X.X.X-XXX.XXX.XXX.rpm
+
# yum install netatalk-X.X.X-XXX.XXX.XXX.rpm
 
</pre>
 
</pre>
 
</tt>
 
</tt>

Revision as of 15:14, 29 November 2016

Personal tools
Namespaces
Variants
Actions
Navigation
Toolbox