Netatalk 3.1.11 SRPM for Fedora and CentOS

From Netatalk Wiki
(Difference between revisions)
Jump to: navigation, search
m
Line 1: Line 1:
 
== Overview ==
 
== Overview ==
 +
See [http://koji.fedoraproject.org/koji/packageinfo?packageID=449 koji site] and [http://pkgs.fedoraproject.org/cgit/rpms/netatalk.git/ git repositories site].
  
There is netatalk-3.1.7-2.fc24 on  [http://koji.fedoraproject.org/koji/packageinfo?packageID=449 koji site].
+
Official netatalk package retired because there were no longer packagers.
However, these packages are incomplete.
+
This page introduces a SRPM of netatalk.
 
+
This page introduces a better SRPM of netatalk.
+
  
 
This SRPM is tested on:
 
This SRPM is tested on:
*Fedora 25 (rawhide 2016/07/20) x86_64
+
*Fedora 26 (rawhide 2016/09/02) x86_64
 +
*Fedora 25 alpha server x86_64
 
*Fedora 24 Server x86_64
 
*Fedora 24 Server x86_64
 
*Fedora 23 Server x86_64
 
*Fedora 23 Server x86_64
Line 269: Line 269:
  
 
== Changelog ==
 
== Changelog ==
 +
2016.09.02
 +
*tested on Fedora 25 alpha Server x86_64 and Fedora 26 (rawhide)
 +
 
2016.07.27 (5:3.1.9-0.1.2)
 
2016.07.27 (5:3.1.9-0.1.2)
 
*Two manpages weren't updated.
 
*Two manpages weren't updated.

Revision as of 18:27, 2 September 2016

Contents

Overview

See koji site and git repositories site.

Official netatalk package retired because there were no longer packagers. This page introduces a SRPM of netatalk.

This SRPM is tested on:

SRPM

Download netatalk-3.1.9-0.1.2.fc25.src.rpm

This SRPM includes netatalk.spec

Build

At least, "rpm-build", "gcc" and "make" packages are needed.

# yum install rpm-build gcc make

or

# dnf install rpm-build gcc make

Install the SRPM.

$ rpm -ivh netatalk-X.X.X-XXX.XXX.src.rpm

The following messages don't have a problem.

warning: group hat does not exist - using root
warning: user hat does not exist - using root

Build by using "rpmbuild" command.
If "error: Failed build dependencies: zzz" is displayed, execute "yum install zzz" or "dnf install zzz".

$ cd ~/rpmbuild/SPECS/
$ rpmbuild -bb netatalk.spec

Install or Upgrade

Install by using rpm" command.
If "error: Failed dependencies: xxx is needed by..." is displayed, execute "yum install xxx" or "dnf install xxx".

If you install the netatalk for the first time, use "-i" option.

$ cd ~/rpmbuild/RPMS/XXX/
# rpm -ivh netatalk-X.X.X-XXX.XXX.XXX.rpm

If the old netatalk already been installed, update by "-U" option.

# rpm -Uvh netatalk-X.X.X-XXX.XXX.XXX.rpm

Check

Check features and paths, using "netatalk -V" and "afpd -V".

$ /usr/sbin/netatalk -V
netatalk 3.1.9 - Netatalk AFP server service controller daemon

This program is free software; you can redistribute it and/or modify it under
the terms of the GNU General Public License as published by the Free Software
Foundation; either version 2 of the License, or (at your option) any later
version. Please see the file COPYING for further information and details.

netatalk has been compiled with support for these features:

     Spotlight support: Yes

                  afpd: /usr/sbin/afpd
            cnid_metad: /usr/sbin/cnid_metad
       tracker manager: /usr/bin/tracker daemon
           dbus-daemon: /usr/bin/dbus-daemon
              afp.conf: /etc/netatalk//afp.conf
     dbus-session.conf: /etc/netatalk//dbus-session.conf
    netatalk lock file: /var/lock/netatalk

$ /usr/sbin/afpd -V
afpd 3.1.9 - Apple Filing Protocol (AFP) daemon of Netatalk

This program is free software; you can redistribute it and/or modify it under
the terms of the GNU General Public License as published by the Free Software
Foundation; either version 2 of the License, or (at your option) any later
version. Please see the file COPYING for further information and details.

afpd has been compiled with support for these features:

          AFP versions: 2.2 3.0 3.1 3.2 3.3 3.4 
         CNID backends: dbd last tdb mysql 
      Zeroconf support: Avahi
  TCP wrappers support: Yes
         Quota support: Yes
   Admin group support: Yes
    Valid shell checks: Yes
      cracklib support: Yes
            EA support: ad | sys
           ACL support: Yes
          LDAP support: Yes
         D-Bus support: Yes
     Spotlight support: Yes
         DTrace probes: Yes

              afp.conf: /etc/netatalk//afp.conf
           extmap.conf: /etc/netatalk//extmap.conf
       state directory: /var/lib/netatalk/
    afp_signature.conf: /var/lib/netatalk/afp_signature.conf
      afp_voluuid.conf: /var/lib/netatalk/afp_voluuid.conf
       UAM search path: /usr/lib64/netatalk//
  Server messages path: /var/lib/netatalk/msg/

In case of EL6, Spotlight is not supported.

Setting Up

Edit "/etc/netatalk/afp.conf".

Ex:

[Global]

[Homes]
    basedir regex = /home

[Test Volume]
    path = /export/test1

[My Time Machine Volume]
    path = /export/timemachine
    time machine = yes

It's recommended to enable extended attributes of filesystem. You can check it by "getfattr" and "setfattr" commands.

If you use ACL, you shoud check it by "getfacl" and "setfacl" commands.

If these are disabled, use "tune2fs" command or edit "/etc/fstab" file.

Ex:

/dev/sdc2    /mountpoint    ext4    defaults,user_xattr,acl    0 2

You should check firewall. AFP's port number is 548. Zeroconf's port number is 5353.

You also should check SELinux. SELinux may interfere with operation of D-Bus.

Enabling and Starting

You must run Avahi ahead of Netatalk.

Fedora and EL7

# systemctl enable avahi-daemon
# systemctl enable netatalk
# systemctl start avahi-daemon
# systemctl start netatalk

EL6

# chkconfig avahi-daemon on
# chkconfig netatalk on
# service avahi-daemon start
# service netatalk start

Spotlight Feature

Fedora and EL7

If you use Spotlight feature, read Spotlight section in Netatalk Manual.

Set "spotlight = yes".

Set "spotlight = no" for Time Machine's volume. The mining for sparsebundle is wasteful.

Ex:

[Global]
    spotlight = yes

[Homes]
    basedir regex = /home

[Test Volume]
    path = /export/test1

[My Time Machine Volume]
    path = /export/timemachine
    time machine = yes
    spotlight = no

There is a bug.

EL6

This package does not support Spotlight because there is no Tracker package.

Changelog

2016.09.02

2016.07.27 (5:3.1.9-0.1.2)

2016.07.20 (5:3.1.9-0.1.1)

2016.06.23

2016.04.30 (5:3.1.8-0.1.5)

2015.12.30 (5:3.1.8-0.1.4)

2015.12.29 (5:3.1.8-0.1.2)

2015.11.07

2015.08.05 (5:3.1.7-1.2)

2015.08.04 (5:3.1.7-1.1)

2015.05.27

2015.04.22

2014.12.02 (4:3.1.7-0.1)

2014.10.30 (4:3.1.6-0.0.4)

2014.08.27 (4:3.1.6-0.0.1)

2014.08.12 (4:3.1.5-0.0.1)

2014.08.07 (4:3.1.4-0.0.1)

2014.07.08

2014.07.03 (4:3.1.3-0.0.1)

2014.06.04 (4:3.1.2-0.0.1)

2014.05.07

2014.04.23 (4:3.1.1-0.0.7)

2014.04.04 (4:3.1.1-0.0.6)

2014.04.02 (4:3.1.1-0.0.5)

2014.03.23 (4:3.1.1-0.0.4)

2014.03.23 (4:3.1.1-0.0.3)

2014.03.18 (4:3.1.1-0.0.2)

2014.03.13 (4:3.1.1-0.0.1)

2014.01.11 (4:3.1.0-0.0.1)

2013.12.27 (4:3.0.6-0.0.2)

2013.12.17

2013.10.26 (4:3.0.6-0.0.1)

2013.08.29 (4:3.0.5-0.0.2)

2013.08.14 (4:3.0.5-0.0.1)

2013.07.02

2013.05.26 (4:3.0.4-0.0.3)

2013.03.26 (4:3.0.3-0.0.7)

2013.03.01 (4:3.0.2-0.0.3)

2013.02.28 (4:3.0.2-0.0.3)

2013.02.27 (4:3.0.2-0.0.2)

2013.01.22 (4:3.0.2-0.0.1)

2013.01.15

2012.10.19 (4:2.2.4-0.0.1)

2012.07.30

2012.07.19 (4:2.2.3-2.3)

2012.07.02 (4:2.2.3-2.2)

2012.06.05

2012.05.23 (4:2.2.3)

2012.01.16 (4:2.2.2)

2011.12.02

2011.09.07 (4:2.2.1-0.1.5)

2011.08.24 (4:2.2.1-0.1.4.git)

2011.08.03 (4:2.2.1-0.1.3.git)

2011.07.30 (4:2.2.1-0.1.2.git)

2011.07.28 (4:2.2.1-0.1.1.git)

2011.07.20 (4:2.2-0.1.2.git)

2011.07.12 (4:2.2-0.1.1.git)

2010.05.15

2010.04.27 (4:2.1-0.1.82)

(4:2.1.0-0.1.81.CVS_HEAD)

(4:2.1.0-0.1.80.CVS_HEAD)

(4:2.1.0-0.1.79.CVS_HEAD)

(4:2.1.0-0.1.78.CVS_HEAD)

2010.04.09 (4:2.1.0-0.1.77.beta2)

(4:2.1.0-0.1.76.CVS_HEAD)

(4:2.1.0-0.1.75.CVS_HEAD)

(4:2.1.0-0.1.74.CVS_HEAD)

(4:2.1.0-0.1.73.CVS_HEAD)

(4:2.1.0-0.1.72.CVS_HEAD)

(4:2.1.0-0.1.71.CVS_HEAD)

(4:2.1.0-0.1.70.CVS_HEAD)

2010.02.15 (4:2.1.0-0.1.69.beta1)

(4:2.1.0-0.1.68.CVS_HEAD)

2010.02.12 (4:2.1.0-0.1.67.CVS_HEAD)

2010.02.07 (4:2.1.0-0.1.66.CVS_HEAD)

2010.01.29 (4:2.1.0-0.1.65.dev)

2010.01.27 (4:2.1.0-0.1.64.dev)

2010.01.24 (4:2.1.0-0.1.63.dev)

2010.01.20 (4:2.1.0-0.1.62.dev)

2010.01.18 (4:2.1.0-0.1.61.dev)

2010.01.07 (4:2.1.0-0.1.60.dev)

2010.01.04 (4:2.1.0-0.1.59.dev)

2009.12.25 (4:2.1.0-0.1.58.dev)

2009.12.21 (4:2.1.0-0.1.57.dev)

(4:2.1.0-0.1.56.dev)

2009.12.19 (4:2.1.0-0.1.55.dev)

2009.12.17 (4:2.1.0-0.1.54.dev)

(4:2.1.0-0.1.53.dev)

(4:2.1.0-0.1.52.dev)

(4:2.1.0-0.1.51.dev)

(4:2.1.0-0.1.50.dev)

2009.09.25 (4:2.1.0-0.1.49.dev)

2009.09.12 (4:2.1.0-0.1.48.dev)

2009.09.05 (4:2.1.0-0.1.47.dev)

2009.09.02 (4:2.1.0-0.1.46.dev)

2009.08.25 (4:2.1.0-0.1.45.dev)

2009.07.22 (4:2.1.0-0.1.44.dev)

2009.07.21 (4:2.1.0-0.1.43.dev)

2009.07.20 (4:2.1.0-0.1.42.dev)

2009.07.12 (4:2.1.0-0.1.41.dev)

2009.07.03 (4:2.1.0-0.1.40.dev)

2009.06.23 (4:2.1.0-0.1.39.dev)

2009.06.09 (4:2.1.0-0.1.38.dev)

2009.03.28 (4:2.1.0-0.1.37.dev)

2009.03.11 (4:2.1.0-0.1.36.dev)

2009.02.01 (4:2.1.0-0.1.35.dev)

2009.01.30 (4:2.1.0-0.1.34.dev)

2009.01.23 (4:2.1.0-0.1.33.dev)

2009.01.13 (4:2.1.0-0.1.32.dev)

2008.11.30 (4:2.1.0-0.1.31.dev)

2008.11.26 (4:2.1.0-0.1.30.dev)

2008.11.22 (4:2.1.0-0.1.29.dev)

2008.08.19 (4:2.1.0-0.1.28.dev)

2008.08.07 (4:2.1.0-0.1.27.dev)

2008.05.23 (4:2.1.0-0.1.26.dev)

2008.05.16 (4:2.1.0-0.1.25.dev)

Personal tools
Namespaces
Variants
Actions
Navigation
Toolbox